Forum upgrade appears to have worked.

Discussion in 'Forum Information and Issues' started by adrian, 7 November 2014.

  1. Steve Cook

    Steve Cook Flying Squad

    daifly - there is an A symbol in the edit bar, clicking that should give you a load of colour options
    HTH
    Steve
    Edited to check I can change colour on an edit
    I can, shame I have no colour taste in this post :p

    I'm on chrome on a Mac, will check Chrome and XP in a minute.
     
  2. Heather Kay

    Heather Kay Western Thunderer

    Up at the top right of your thread's first post is a small drop down menu of tools. I think the edit features are in there. :thumbs:
     
    Steve Cook likes this.
  3. Steve Cook

    Steve Cook Flying Squad

    Thanks Heather :)
    Can't see for looking... :oops:
    Steve
     
  4. daifly

    daifly Western Thunderer

    Bizarre - it would NOT do that earlier. Thanks all.
     
  5. daifly

    daifly Western Thunderer

    Just tried again and failed. To reproduce this, write a piece of text and embed a link. Now try to change the link colour!

    I rest my case.

    Edit by Steve Cook. Challenge accepted :)

    For reference, the word link was originally bold, but black text.
     
    Last edited by a moderator: 9 November 2014
  6. Steve Cook

    Steve Cook Flying Squad

    If this works daifly, it should take you to the top of the page.

    Process was write sentence, highlight text, insert link, change colour.

    In order to give Adrian the best chance of fixing this (did you see the teflon shoulder pads there), can you let us know what device you are trying it on please?

    Steve
     
  7. daifly

    daifly Western Thunderer

    It's a Macbook Pro 2014 using Firefox 33.0.3. Interesting that you can change this but I can't.
     
  8. daifly

    daifly Western Thunderer

    Unless I use Safari to edit. Hmm
     
  9. daifly

    daifly Western Thunderer

    Just upgraded to Firefox 33.1 and the problem remains. Very odd.
     
  10. daifly

    daifly Western Thunderer

    I note that the post counter has disappeared from below the avatar.
     
  11. ZiderHead

    ZiderHead Western Thunderer

    Perhaps the link fixed colour isn't a problem but intended behaviour - if the link colour is consistent people know what is a clickable link? Its how I would do it.
     
  12. daifly

    daifly Western Thunderer

    I'm sure that it's not intended behaviour. As Steve Cook illustrated here it can be done. My investigations show that I can't do it using a Firefox/MBPro combination. This post was created using Safari/MBPro and all works well. I use Firefox most of the time because I have had some problems with Safari when attempting Online Banking etc. Perhaps I shall have to set Safari as my default browser.
    Dave
     
  13. rosspeacock

    rosspeacock Modelling on a £1200 table.

    I'd like to be able to see the full version on my Galaxy S3 not sure I like the version I'm getting now..

    Ross.. :)
     
  14. Steph Dale

    Steph Dale Western Thunderer

  15. adrian

    adrian Flying Squad

    Yes it does seem to be a bug (or "feature") in the editor specific to Firefox, I can recreate it on my Mac Air with Firefox.

    It seems what is happening on Firefox is that the colour tags are being applied outside of the url tags, if you look at the BB code then Firefox gives this
    Code:
    [COLOR=#0000ff][url ref=...]Link Text[/url][/COLOR]
    
    Yet on Safari or Chrome etc the color tags are inside the url tag.
    Code:
    [url ref=...][COLOR=#0000ff]Link Text[/COLOR][/url]
    
    So in the Firefox generated message the url tag formatting overrides the colour you have set.

    I'll file it as a bug with the forum software people. For the minute it means either moving the color tags around or after creating the link you can apply the colour to half of the link text first and then the other half in a second go - this is created on a MacAir with Firefox. I'll try and work on a better fix for you.
     
  16. Phill Dyson

    Phill Dyson Western Thunderer

  17. Phill Dyson

    Phill Dyson Western Thunderer

    This does work though Ross.
     
    adrian likes this.
  18. adrian

    adrian Flying Squad

    It seems a recurring problem that the links in messages weren't visible enough, rather than the members continually editing links to make them visible I have updated the styling so now any links in messages should be more prominent.

    I hope this helps.
     
    daifly likes this.
  19. daifly

    daifly Western Thunderer

    Hi Adrian
    Thanks for confirming that it wasn't just me! I haven't tried it yet with a PC/Firefox combo - have you?
    Cheers
    Dave
     
  20. adrian

    adrian Flying Squad

    Not yet - I don't have easy access to that combination. I run Templot through a virtual Win7 machine at home so I'd have to fire that up and install Firefox to test it out.